NewsXS banner

Auteur Topic: Spotweb installatie - eerste keer opstarten werkt niet  (gelezen 410 keer)

0 leden en 1 gast bekijken dit topic.

november 11, 2020, 15:37:53 pm
gelezen 410 keer

sentinall

  • *
  • Information Offline
  • Newbie
  • Berichten: 8
Hoi hoi,

Ik heb mijn synology nas ingericht conform de stappen op de site. (dus met een statisch ip adres)
Config File Editor geinstalleerd
WinSCP geinstalleerd
Mariadb5 geinstalleerd
spotweb geinstalleerd.

Nu wil ik mijn config afronden door naar de install URL te gaan: http://192.168.1.32/spotweb/install.php

Echter zodra ik deze uitvoer wordt ik gelijk geroute naar mijn synology nas homepage: http://192.168.1.32:5000/

Ik kom dus niet in het installatiescherm

iemand enig idee?

november 11, 2020, 15:49:32 pm
Reactie #1

sentinall

  • *
  • Information Offline
  • Newbie
  • Berichten: 8
ben een stapje verder, want ik had webstation niet geinstalleerd.

dit gedaan, echter nu krijg ik een error: 500 "there is an error while processing this request"

november 11, 2020, 17:43:26 pm
Reactie #2

snelrennen

  • *****
  • Information Man Offline
  • Hero Member
  • Administrator
  • Berichten: 2649
    • Snelrennen
Even alles verwijderen, Spotweb, database e.d. en dan opnieuw beginnen, nu met webstation ge?nstalleerd.

november 12, 2020, 11:28:08 am
Reactie #3

sentinall

  • *
  • Information Offline
  • Newbie
  • Berichten: 8

Hoi,

Ik dit heb ik gedaan en ben weer een stap verder.

Ik heb alle geinstalleerde applicaties verwijderd (inclusief eventuele databases).
Nas opnieuw opgestart.
en opnieuw geinstalleerd.

So far so good.

Ga ik verder met spotweb installatie:

Handmatig installeren Spotweb met het bestand van het forum (Spotweb_noarch-all_20190917-1)
<De vraag m.b.t. de spotweb database configuratie tijdens het installeren krijg ik niet>

Alles is nu geinstalleerd en gestart.

Nu ga ik in mijn browser naar: http://192.168.1.32/spotweb/install.php

en nu doet hij het wel.
Eerste scherm staat alles op OK. Dat is mooi, klik op next
komen we bij de DB settings en hier krijg ik een error als ik de database verifier

SQLSTATE[HY000] [1045] Access denied for user 'spotweb'@'localhost' (using password: NO)

Please correct the errors in below form and try again


Dit moet te maken hebben met het feit dat ik geen database vraag kreeg bij het installeren van spotweb.

enig idee?



november 12, 2020, 11:43:24 am
Reactie #4

sentinall

  • *
  • Information Offline
  • Newbie
  • Berichten: 8
toch gelukt, ik moest de Maria DB password ingeven.

Nu heb ik alles netjes geconfigureerd en probeer ik de eerste keer spots op te halen, helaas krijg ik geen resultaten.

in de handleiding staat:
Mocht het updaten van Spotweb niet lukken met de update knop in het programma kun je vis SSH handmatig "Retrieve.php" uitvoeren. Heb je geen idee waar dit over gaat kun je ook met behulp van de taakplanner dit uit laten voeren.

Dit is me gelukt, ik heb een taakje de retrieve.php eenmalig laten uitvoeren en vervolgens heb ik een regel ingesteld dat deze iedere 2 uur loopt (dagelijks tussen 06:00 en 22:00).

Helaas krijg ik geen resultaten.
Ik heb beide zoekmachines een keer ingesteld. binsearch en nzbindex.

nog tips?


november 13, 2020, 02:12:03 am
Reactie #5

snelrennen

  • *****
  • Information Man Offline
  • Hero Member
  • Administrator
  • Berichten: 2649
    • Snelrennen
Je moet er nog geen terugkerende taak van maken, de eerste keer 1 maal uit laten voeren en als je database dan gevuld is kun je hem regelmatig bij laten werken met een taak.

november 13, 2020, 09:20:21 am
Reactie #6

sentinall

  • *
  • Information Offline
  • Newbie
  • Berichten: 8
Yes zover ben ik gekomen, alleen werkt de repeterende taak nog niet.

Het handmatig updaten van spotweb werkt, echter als ik de taak plan voert de nas het commando niet uit.
Control panel > Task scheduler
Create > scheduled Task > user defined script

task: Spotweb Update
Daily: every hour
from: 00:06 to 23:06

Run Command:
/volume1/web/spotweb/retrieve.php

path / bestand klopt, dus ik vraag me af wat ik fout doe?


B.t.w. bedankt voor de uitgebreide handleidingen, echt super!

november 13, 2020, 09:30:08 am
Reactie #7

sentinall

  • *
  • Information Offline
  • Newbie
  • Berichten: 8
Het gekke is, in de logging zegt hij:
/volume1/web/spotweb/retrieve.php: line 1: ?php: No such file or directory
/volume1/web/spotweb/retrieve.php: line 2: syntax error near unexpected token `2147483647'
/volume1/web/spotweb/retrieve.php: line 2: `error_reporting(2147483647);'

Echter deze path bestaat wel, zie bijlage.

het zal vast iets simpels zijn dat ik verkeerd doe, maar ik zie het niet

november 13, 2020, 09:36:53 am
Reactie #8

sentinall

  • *
  • Information Offline
  • Newbie
  • Berichten: 8
lezen lezen lezen :-)

Er moest nog een commanda voor:
/usr/local/bin/php73 /volume1/web/spotweb/retrieve.php

Het wekrt nu, er mag een slotje op dit topic!

Bedankt voor de hulp

Snelrennen

Re: Spotweb installatie - eerste keer opstarten werkt niet
« Reactie #8 Gepost op: november 13, 2020, 09:36:53 am »